Unable to execute Java when starting service

The Pulse Support forums are here so that you can ask questions or leave comments related to pulse. They are watched by Zutubi staff who will endeavour to answer your questions promptly.

Unable to execute Java when starting service

Postby scoobydoo on Wed Apr 15, 2015 8:34 pm

I have been running Pulse for a while and all has been good. Today i noticed that builds were not running. On further investigation i see that the agent machine restarted due to a Windows update. The agent is setup as a service, so it should have started automatically. So i go to restart the agent service anyway and then i see the following error. My java version is 1.8.0_45-b14

I think the java was recently updated also so maybe that's the issue?

Any ideas appreciated. Thanks.

--------------

STATUS | wrapper | 2015/04/15 10:27:32 | --> Wrapper Started as Service
STATUS | wrapper | 2015/04/15 10:27:32 | Launching a JVM...
FATAL | wrapper | 2015/04/15 10:27:32 | Unable to execute Java command. The system cannot find the file specified. (0x2)
FATAL | wrapper | 2015/04/15 10:27:32 | "C:\Program Files (x86)\Java\jre7\bin\java" -Dpulse.home=.. -Djava.awt.headless=true -Djava.util.logging.config.class=com.zutubi.pulse.logging.ConsoleConfig -XX:MaxPermSize=128m -Xmx1024m -Djava.library.path="../lib" -classpath "../lib/wrapper.jar;../lib/boot.jar" -Dwrapper.key="5rHISOoNo6f2cLly" -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.pid=2332 -Dwrapper.version="3.2.3" -Dwrapper.native_library="wrapper" -Dwrapper.service="TRUE" -Dwrapper.cpu.timeout="10" -Dwrapper.jvmid=1 org.tanukisoftware.wrapper.WrapperStartStopApp com.zutubi.pulse.command.PulseCtl 1 start com.zutubi.pulse.command.PulseCtl true 1 stopservice
FATAL | wrapper | 2015/04/15 10:27:32 | Critical error: wait for JVM process failed
scoobydoo
 
Posts: 28
Joined: Tue Oct 14, 2014 6:39 pm

Re: Unable to execute Java when starting service

Postby scoobydoo on Wed Apr 15, 2015 9:44 pm

In case anyone has a similar issue, i'm posting a solution i found. For me the issue was that i had a Java update and for some reason that messed things up. I uninstalled Java, re-installed Pulse (which re-installed it's own Java runtime) and everything is working again.
scoobydoo
 
Posts: 28
Joined: Tue Oct 14, 2014 6:39 pm

Re: Unable to execute Java when starting service

Postby jason.sankey on Thu Apr 16, 2015 12:21 am

Hi,

Thanks for following up with a solution that works for you. I think what may have happened is your Java moved on update and maybe there was an old JAVA_HOME setting that was no longer valid. The new install probably also failed to detect your Java 1.8, so installed its own and pointed JAVA_HOME at that one. Java 1.8 is supported with Pulse, but the older installers won't necessarily find it.

Note that the service infrastructure has changed in Pulse 2.7+, so some or all of this probably won't apply to newer versions too.

Cheers,
Jason
jason.sankey
 
Posts: 1815
Joined: Sun Apr 30, 2006 12:26 pm


Return to Pulse Support

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests

cron