Qtestlib test failing

The Pulse Support forums are here so that you can ask questions or leave comments related to pulse. They are watched by Zutubi staff who will endeavour to answer your questions promptly.

Qtestlib test failing

Postby scoobydoo on Tue Nov 18, 2014 8:48 pm

I have a test that's using the Qt testing framework. It's a very simple test that checks the return code from a process to make sure it returns 0 ( QProcess::NormalExit ) The test is started from a batch file. When i run it from the command line, the test runs and completes without error. When i run the same batch file from Pulse it keeps on failing saying that the process exit status was not equal to a normal exit.

I'm pretty stumped on this one. In both cases i am running the test on the same machine, same user account. Any idea why i would see different results when running from Pulse?
scoobydoo
 
Posts: 28
Joined: Tue Oct 14, 2014 6:39 pm

Re: Qtestlib test failing

Postby jason.sankey on Tue Nov 18, 2014 11:00 pm

Hi,

As you are running on the same machine and with the same user, I guess it is something else about the environment in which the process is being launched when under Pulse. The two things that come to mind are the working directory (which, by default, will be somewhere under the Pulse build's base directory) and environment variables. Do you know if the tested process is sensitive to either of these? Does the tested process produce any output, and if so are you able to check it (because it is run indirectly by your test case I'm not sure if its output is being sent/captured anywhere?).

Cheers,
Jason
jason.sankey
 
Posts: 1815
Joined: Sun Apr 30, 2006 12:26 pm


Return to Pulse Support

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests

cron